K8200 sur PC ubuntu ?

Voir le sujet précédent Voir le sujet suivant Aller en bas

K8200 sur PC ubuntu ?

Message par statis le Sam 22 Mar - 20:36

Quelqu'un a réussi à installer la K8200 sur un Ubuntu 64bits ?
avatar
statis

Messages : 1138
Date d'inscription : 18/03/2014

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: K8200 sur PC ubuntu ?

Message par TB1065 le Lun 24 Mar - 8:23

salut,
je n'ai pas encore essayé, mais je suis tres tenté.
sur les 5 PC de la maison, il n'y en a plus qu'un sous WinDaube: celui pour l'imprimante.
bien que j'imprime de plus en plus avec le module LCD autonome, l'imprimante est juste à coté du PC.
si je pouvais utiliser Ubuntu ( 32) je serais heureux de ne plus avoir de Windows à la maison...

je suis en congé la semaine de Pâques. j'essayerais à ce moment.

TB1065

Messages : 165
Date d'inscription : 13/01/2014
Age : 52
Localisation : La Louvière

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: K8200 sur PC ubuntu ?

Message par statis le Lun 24 Mar - 13:33

J'ai suivi ce tuto qui paraissait plus sérieux que celui du forum paswell http://hacklab.fr/impression-3d-sous-ubuntu.html mais j'ai eut des erreurs et en finalité quand j'essaye de connecter l'imprimante j'ai un message "5 demandes en attente" et rien d'autre. Je fais essais sur essais donc je ne pourrais pas savoir quel a été le bon process car ne connaissant bien linux (ubuntu 64bits) je fais souvent des choses sans comprendre lol Heureusement j'ai un vieux PC 1méga de ram qui est arrivé à imprimer le fan nozzle...
avatar
statis

Messages : 1138
Date d'inscription : 18/03/2014

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: K8200 sur PC ubuntu ?

Message par statis le Lun 24 Mar - 23:38

Bon, j'y suis arrivé en utilisant à plusieurs reprises les deux tutos http://hacklab.fr/impression-3d-sous-ubuntu.html et https://github.com/repetier/Repetier-Host/issues/156 plus des commandes sudo adduser <mon nom d'utilisateur> tty et sudo usermod -a -G dialout <mon nom d'utilisateur> ainsi que l'installation de automake via le gestionnaire de paquets synaptics si je n'oublie rien, si un autre arrive à être plus ordonné que moi et faire un plan utilisable par tous du style "pas besoin" d'installer le driver, j'ai essayé donc je ne sais pas si on peut s'en passer, etc, etc, cela serait sympa pour ceux qui voudraient utiliser leur k8200 sur un Linux Wink
avatar
statis

Messages : 1138
Date d'inscription : 18/03/2014

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: K8200 sur PC ubuntu ?

Message par TB1065 le Mar 25 Mar - 7:10

Super,
c'est bon signe, je vais essayer de m'y mettre ce week-end si je trouve qq heures de libre...

encore félicitation


TB1065

Messages : 165
Date d'inscription : 13/01/2014
Age : 52
Localisation : La Louvière

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: K8200 sur PC ubuntu ?

Message par statis le Jeu 27 Mar - 22:24

J'ai chargé le nouveau firmware pour l'extension qui rend la k8200 autonome.
Aucun problème une fois le zip arduino récupéré et le script du dossier lancer, sans avoir de compil à faire, le soft c'est lancé et j'ai pu faire la mise à jour avec succès Wink
Plus besoin du PC windows, repetier tourne bien sur mon ubuntu 64bits et plus besoin de monopoliser l'ordi Wink
avatar
statis

Messages : 1138
Date d'inscription : 18/03/2014

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: K8200 sur PC ubuntu ?

Message par statis le Ven 15 Aoû - 17:25

malheureusement du temps a passé et des mises à jour que je n'aurais jamais du faire, tout comme installer la version repetier préconisée par velleman...
Je suis complètement bloqué et ma connexion "série" émulée et patchée doit poser problème...
D'ailleurs velleman aurait du fournir un firmware pour les utilisateur de linux pour éviter de travailler en 250000 ou au moins faire un tutorial pour le modifer !!!
Sur mon linux j'ai entre autres, des doubles entrées de clef qui posent problème et malgré avoir essayé de "nettoyer" à la mode bourrin qui connait rien, pas moyen de revenir à un OS propre pour recommencer une install propre sans avoir à tout reformater, ce qui serait impensable car il me faudrait des jours pour réinstaller mes applications autres que celle dédiées à l'impression 3D.
Si une bonne âme qui connaît bien linux passait par là, cela serait une agréables surpise...
avatar
statis

Messages : 1138
Date d'inscription : 18/03/2014

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: K8200 sur PC ubuntu ?

Message par Talocks le Dim 17 Aoû - 9:19

Tu as finalement réussi à installer Mono sans message d'erreur ?
Que donnes comme résultat les commandes "dmesg | grep FTDI" et "lsusb" ?

Si c'est le cas, j’essayerai d'abord d'installer la version 0.84 indiquée dans ce tuto :

http://v1.hacklab.fr/index.php?option=com_content&view=article&id=39:impression-3d-sous-ubuntu

Question bête (je demande car je me suis fais avoir ^^ ), au chapitre 7 de configuration de Repetier, tu as bien remplacé util01 par ton nom d'utilisateur sous Ubuntu ?

sudo usermod -a -G dialout util01
et
sudo adduser util01 tty

Talocks

Messages : 73
Date d'inscription : 06/05/2014

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: K8200 sur PC ubuntu ?

Message par statis le Dim 17 Aoû - 11:17

Bonjour Talocks,
Oui mono c'est installé sans erreurs...
Et les commandes de contrôle répondent bien.
[ 678.186081] usb 5-1: Manufacturer: FTDI
[ 678.297528] usbserial: USB Serial support registered for FTDI USB Serial Device
[ 678.297632] ftdi_sio 5-1:1.0: FTDI USB Serial Device converter detected
[ 678.300963] usb 5-1: FTDI USB Serial Device converter now attached to ttyUSB0

Bus 001 Device 004: ID 0bf8:100f Fujitsu Siemens Computers miniCard D2301 802.11bg Wireless Module [SiS 163U]
Bus 001 Device 003: ID 05e3:0710 Genesys Logic, Inc. USB 2.0 33-in-1 Card Reader
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 002: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 04f3:0234 Elan Microelectronics Corp.
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

L'utilisateur « pcl64 » appartient déjà au groupe « tty ».

La version 0.90D ne me posait pas de problème et maintenant en regardant mieux j'ai une piste car au moment de la connexion le soft se ferme alors qu'il s'était ouvert correctement j'ai en tête de liste dans le terminal le message suivant en 250000 et 111112:
System.ArgumentOutOfRangeException: Given baud rate is not supported on this platform.
Si je paramètre en 115200, là çà plante pas mais j'ai les "x comandes en attente"...

En fait quand j'installe le patch il se passe çà :
patching file ./support/serial.c
Reversed (or previously applied) patch detected! Assume -R? [n]

Sinon en remettant la 0.84 de m.... toujours le même problème en 250000 :
System.ArgumentOutOfRangeException: Given baud rate is not supported on this platform.
Parameter name: baudRate
at System.IO.Ports.SerialPortStream.TryBaudRate (Int32 baudRate) [0x00000] in <filename unknown>:0
at System.IO.Ports.SerialPortStream..ctor (System.String portName, Int32 baudRate, Int32 dataBits, Parity parity, StopBits stopBits, Boolean dtrEnable, Boolean rtsEnable, Handshake handshake, Int32 readTimeout, Int32 writeTimeout, Int32 readBufferSize, Int32 writeBufferSize) [0x00000] in <filename unknown>:0
at (wrapper remoting-invoke-with-check) System.IO.Ports.SerialPortStream:.ctor (string,int,int,System.IO.Ports.Parity,System.IO.Ports.StopBits,bool,bool,System.IO.Ports.Handshake,int,int,int,int)
at System.IO.Ports.SerialPort.Open () [0x00000] in <filename unknown>:0
at (wrapper remoting-invoke-with-check) System.IO.Ports.SerialPort:Open ()
at RepetierHost.model.PrinterConnection.open () [0x00000] in <filename unknown>:0
at RepetierHost.Main.toolConnect_Click (System.Object sender, System.EventArgs e) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ToolStripSplitButton.OnButtonClick (System.EventArgs e) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ToolStripSplitButton.HandleClick (Int32 mouse_clicks, System.EventArgs e) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ToolStripItem.FireEvent (System.EventArgs e, ToolStripItemEventType met) [0x00000] in <filename unknown>:0
at (wrapper remoting-invoke-with-check) System.Windows.Forms.ToolStripItem:FireEvent (System.EventArgs,System.Windows.Forms.ToolStripItemEventType)
at System.Windows.Forms.ToolStrip.OnMouseUp (System.Windows.Forms.MouseEventArgs mea) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control.WmLButtonUp (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ScrollableControl.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ToolStrip.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control+ControlWindowTarget.OnMessage (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.Control+ControlNativeWindow.WndProc (System.Windows.Forms.Message& m) [0x00000] in <filename unknown>:0
at System.Windows.Forms.NativeWindow.WndProc (IntPtr hWnd, Msg msg, IntPtr wParam, IntPtr lParam) [0x00000] in <filename unknown>:0

Unhandled Exception:
System.ArgumentException: A null reference or invalid value was found [GDI+ status: InvalidParameter]
at System.Drawing.GDIPlus.CheckStatus (Status status) [0x00000] in <filename unknown>:0
at System.Drawing.Graphics.GdipMeasureString (IntPtr graphics, System.String text, System.Drawing.Font font, System.Drawing.RectangleF& layoutRect, IntPtr stringFormat) [0x00000] in <filename unknown>:0
at System.Drawing.Graphics.MeasureString (System.String text, System.Drawing.Font font, Int32 width, System.Drawing.StringFormat format) [0x00000] in <filename unknown>:0
at (wrapper remoting-invoke-with-check) System.Drawing.Graphics:MeasureString (string,System.Drawing.Font,int,System.Drawing.StringFormat)
at System.Windows.Forms.TextRenderer.MeasureTextInternal (IDeviceContext dc, System.String text, System.Drawing.Font font, Size proposedSize, TextFormatFlags flags, Boolean useMeasureString) [0x00000] in <filename unknown>:0
at System.Windows.Forms.TextRenderer.MeasureText (System.String text, System.Drawing.Font font, Size proposedSize, TextFormatFlags flags) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ToolStripItem.OnParentChanged (System.Windows.Forms.ToolStrip oldParent, System.Windows.Forms.ToolStrip newParent) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ToolStripItem.set_Parent (System.Windows.Forms.ToolStrip value) [0x00000] in <filename unknown>:0
at (wrapper remoting-invoke-with-check) System.Windows.Forms.ToolStripItem:set_Parent (System.Windows.Forms.ToolStrip)
at System.Windows.Forms.ToolStripItemCollection.Remove (System.Windows.Forms.ToolStripItem value) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ToolStripItem.Dispose (Boolean disposing) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ToolStripDropDownItem.Dispose (Boolean disposing) [0x00000] in <filename unknown>:0
at System.Windows.Forms.ToolStripMenuItem.Dispose (Boolean disposing) [0x00000] in <filename unknown>:0
at System.ComponentModel.Component.Finalize () [0x00000] in <filename unknown>:0




avatar
statis

Messages : 1138
Date d'inscription : 18/03/2014

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: K8200 sur PC ubuntu ?

Message par statis le Dim 17 Aoû - 12:40

je viens de refaire l'installation de mono et en fait j'ai des erreurs qui apparaissent, le make peut se faire mais mono ne s'installe à priori pas correctement.
R.I.P K8200
avatar
statis

Messages : 1138
Date d'inscription : 18/03/2014

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: K8200 sur PC ubuntu ?

Message par KorpuS le Lun 18 Aoû - 7:23

J'utilise la K8200 avec un PC sous Xubuntu (Ubuntu avec l’environnement Xfce) mais j'ai j'ai dû bidouiller un peu.

Je n'utilise plus RepetierHost mais le couple Slic3r 1.1.7 / Pronterface et ça fonctionne très bien. J'avais des soucis de micro-interruption avec RepetierHost (même en 250000 bauds) que je n'ai pas dans Pronterface.

Le souci avec une distribution Linux récente, c'est que RepetierHost ne supporte pas une version de Perl supérieur à la 5.14 je crois alors que maintenant on en est à la 5.20.

Pour le patch de la liaison série, c'est pareil, il ne fonctionne plus si ta distribution est trop récente, c'est installé mais ça ne change pas grand chose.

Un conseil, passe ton firmware en 115200 bauds, tu seras du coup compatible avec d'autres logiciels et plus besoin de patch. Pour cela tu télécharge le firmware, tu l'ouvres avec l'IDE Arduino, comme dans la doc mais avant de la flasher il suffit juste de modifier la ligne :

Code:

#define BAUDRATE 250000
en
Code:

#define BAUDRATE 115200
dans l'onglet Configuration.h.

Après tu peux flasher et n'oublit pas de repasser tes logiciels en 115200 bauds pour te connecter.

KorpuS

Messages : 34
Date d'inscription : 01/06/2014

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: K8200 sur PC ubuntu ?

Message par statis le Ven 5 Sep - 22:16

Bon avec une distri 12.04 à jour (nouvelle install donc pas d'autre choix) pas moyen d'utiliser repetier comme avec la 14.04 mais pronterface fonctionne en 250000...
K8200 et repetier doivent être cousins...
Si je recupere un de mes anciens gcode tout va bien.
Je n'ai pu installer ni slic3r ni skeinforge sur pronterface, aucun tuto valable...
En utilisant skeinforge je ne peux trouver le point central et bien sûr aucun tuto pour la k8200...
En ayant installé slic3r selon un tuto à la "con" et en le lançant avec ./slicr3r.pl je peut générer du gcode mais alors que le périmètre se fait la première couche ne tient pas et on dirait que le fil ne sort pas. Si j'utilise un autre .ini que celui de velleman slic3r plante à la génération, si je le modifie trop pareil...
Avant il me suffisait de mettre 203°/203° (normal en vrai je suis à 185° à cause du super matois velleman) pour la buse en 0.5 filament (PLA) 2.8 et 60°/50° et j'arrivais à imprimer
J'en ai marre...
Quelqu'un connaît la méthode pour en pas utiliser github mais prendre la dernière version sur le site officiel slic3r et le compiler ?
Et/Ou mieux comment paramétrer skeinforge pour cette pu..... de k8200 ?
Comment intégrer l'un et/ou l'autre à pronterface serait aussi bienvenu...
Un conseil à ceux qui lise ce post, si vous avez un PC en linux, oubliez l'impression 3D et si çà fonctionne chez vous allez mettre un cierge à Lourdes quand vous faites une mise à jour car vous risquez de tout planter et sur les forums "officiels" on vous dira de réinstaller complètement l'OS comme à l'époque de windows quand il fallait tout reformater...
avatar
statis

Messages : 1138
Date d'inscription : 18/03/2014

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: K8200 sur PC ubuntu ?

Message par KorpuS le Sam 6 Sep - 9:34

Ma Xubuntu est une 13.10 (64 bits). Et j'ai bloqué les mise à jour à une version supérieur pour RepetierHost (à cause de Perl) mais je ne l'utilise plus, donc théoriquement, je peux utiliser la dernière Xubuntu en virant Repetier.

Je n'ai effectué aucune compilation. Slic3r n'est pas intégré à Pronterface, je l'utilise pour trancher en déposant un objet sur le "plater", je sauve le gCode que je récupère après dans Pronterface.

Mon installation est la suivante:
Dans mon répertoire perso, je me suis fais un répertoire Imprim3D.
Dans celui-ci j'ai téléchargé et décompressé Slic3r (http://dl.slic3r.org/linux/slic3r-linux-x86_64-1-1-7-stable.tar.gz). Slic3r est prêt à l’emploi en le lançant avec ~/Imprim3D/Slic3r/bin/slic3r

Pour Pronterface, tu dois avoir Python et plusieurs modules installés:
sudo apt-get install python-serial python-wxgtk2.8 python-pyglet python-tk

Tu dois avoir Git aussi:
sudo apt-get install git

Tu te place dans le répertoire Imprim3D et tu clone:
git clone https://github.com/kliment/Printrun.git

Tu vas obtenir un nouveau répertoire "Printrun" et tu lance Pronterface avec ~/Imprim3D/Printrun/pronterface.py

Tout ça plus la mise à jour du Firmware en V2 avec la vitesse réduite à 115200 bauds, ça fonctionne très bien chez moi.

Quand au fait de reformater le système, il n'y a aucune raison sauf incompatibilité avec un élément essentiel comme la libc ou une version trop récente de Perl (qui est un élément de base) qui ne plait pas à Repetier car il n'est pas fichu d'être compatible.

KorpuS

Messages : 34
Date d'inscription : 01/06/2014

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: K8200 sur PC ubuntu ?

Message par statis le Sam 6 Sep - 23:05

Merci KorpuS

J'ai chargé Slic3r dernière version et j'ai pu le lancer.
Pronterface fonctionne bien en 250000 chez moi sur ma 12.04 32bits.
Je n'ai pas eut le temps de tester une impression avec lui et j’espère qu'il va pas buguer comme la version perl qui est donnée sur github...
Là je pense que c'est enfin la sortie du tunnel...
Avantage à force de chercher et en ayant pu installer pronterface je vais enfin pouvoir calibrer les axes x,y,z et l'extrudeur Wink

Ma 14.04 64bits a été flinguée par la première install préconisée par velleman avec la .84 de repetier toute pourrie et les "essais" fait ensuite. J'ai essayé plein de conseil sur différents forums reprap et le bilan est lourd...
Je ne peux plus utiliser synaptic, les fenêtres disparaissent quand je les réduit, les softs plantent, j'ai constamment des erreurs système, en plus de ne plus pouvoir utiliser l'imprimante. Sur les forums Ubuntu il m'a été conseillé de tout réinstaller, zont pas de solutions pour mon cas...
Je déconseille fortement les utilisateurs linux d'utiliser repetier car il fonctionne avec un bricolage mono qui a priori pilote des softs PC donc du n'importe quoi...
A priori repetier a besoin de perl pour slicr3r (même version que celle donnée par github), sauf peut-être pour la dernière version qui a de la pubn qui est moche et moins fonctionnelle que les précédentes...
Dans le catalogue Ubuntu de la version 14.04 64bits il y a repsnapper mais j'ai pas pu l'essayer...

Bon maintenant il faut que j'arrive à imprimer correctement mes premières couches alors que je n'avais plus ce problème quand çà fonctionnait sur ma 12.04 64bits
avatar
statis

Messages : 1138
Date d'inscription : 18/03/2014

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: K8200 sur PC ubuntu ?

Message par Tag le Dim 7 Sep - 15:29

statis, je suis heureux que tu continues à persévérer comme tu m'avais dis de le faire, la K8200 est une sacré aventure Wink

Tag

Messages : 701
Date d'inscription : 26/03/2014
Age : 50

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: K8200 sur PC ubuntu ?

Message par KorpuS le Lun 8 Sep - 7:57

C'est sûr que quand ton système commence à partir en live comme ça, il n'y a pas grand chose à faire. Vu que souvent c'est un paquet sensible qui est dépendant d'un autre paquet, qui est dépendant encore d'un autre qui dépend du premier, c'est un peu la loose...

Entièrement d'accord pour Repetier sous Linux, quand j'ai vu ce bricolage, plus les efforts à fournir pour espérer avoir un truc qui démarre, j'ai cherché à savoir comment faisaient les autres, et je suis tombé sur Pronterface.

Le seul truc qui m'a gêné avec le couple Slic3r / Pronterface, c'est que Slic3r n'est capable de faire pivoter une pièce uniquement sur l'axe Z. Du coup, je suis en train de me former à Blender, qui fonctionne à merveille sur Linux.

Si tu veux, je peux te filer ma config de Slic3r, j'en suis plutôt content, après avoir utilisé tout une bobine de PLA blanc pour la peaufiner, ce serai dommage Smile

Pour finir sur mon installation, j'ai aussi installé MeshLab pour simplifier certains objets et Netfabb Basic pour en corriger automatiquement et aucun souci d'install et d'utilisation sous Linux.

KorpuS

Messages : 34
Date d'inscription : 01/06/2014

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: K8200 sur PC ubuntu ?

Message par statis le Jeu 11 Sep - 21:07

Merci Tag pour les encouragements Wink

Merci aussi Korpus, ta config Slic3r est intéressante à partager dans un sujet dédié comme par exemple http://3dprinting.forumactif.org/t6-reglage-slic3r
Ce sujet serait bien alimenté, avec le type de filament utilisé, les modifs firmware et matériel allant avec la config slic3r. De mon côté j'ai rien à proposer car chaque jour je découvre un défaut à corriger sur la k8200...

Blender fonctionne très bien sur Linux mais les tutos que l'on trouve sont lourds et pour le dessin de pièces c'est très laborieux, pour les modifs de stl il m'a sauvé la mise.

Avant que tout plante j'utilisais Freecad avec lequel j'ai dessiné toutes les modifs que j'ai faites, le soft permet toutes les rotations et peut même modifier du stl mais la cotation est difficile à gérer dans ce cas.

Freecad, Slic3r (sous réserves) et Pronteface sont certainement une bonne équipe sur Linux, dommage pour l'instant je n'ai pas le temps de chercher d’où viennent mes problèmes abordé dans un autre post.

Skeinforge est dans le catalogue Ubuntu, c'est bon signe mais je crois que ceux qui savent l'utiliser n’achèterons jamais une k8200 vu le peu de tutos dédiés dispos...
avatar
statis

Messages : 1138
Date d'inscription : 18/03/2014

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: K8200 sur PC ubuntu ?

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum