CONFIG EEPROM

Aller en bas

CONFIG EEPROM

Message par PAPILLON le Mar 29 Juil - 9:17

Bonjour .

je viens de remplacer la vis z d'origine (k8200) au pas de 1.25 par une vis hexagonale au pas de 1.5 .

je n'ai pas trouvé le moyen de modifier ce parametre dans repetier . la commande config eeprom est invalidée . et la commande lead screw calculator ne donne rien
Il y a t'il une methode particuliere pour ce faire et si oui (j esoère) laquelle .?
merci pour vos conseils.

amicalement
Philippe

PAPILLON

Messages : 87
Date d'inscription : 03/06/2014

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: CONFIG EEPROM

Message par TheBugLife le Mar 29 Juil - 17:49

Tu dois utiliser le
a plateforme de programmation arduino (la dernière doit fonctionner) puis modifier le fichier configuration.h.

Voici ma modification apportée pour la vis TR :
//#define DEFAULT_AXIS_STEPS_PER_UNIT {64.25,64.25,2560,600} // default steps per unit for ultimaker
#define DEFAULT_AXIS_STEPS_PER_UNIT {64.25,64.25,1600,746} // default steps per unit for ultimaker

Et celle pour avoir accès à l'EEPROM :
#define EEPROM_CHITCHAT (retirer la mise en commentaire de cette ligne)

Ensuite il faut compiler le programmer puis le telecharger dans la carte de l'imprimante sans oublier de faire le shunt comme indiqué dans la notice utilisateur :
http://www.k8200.eu/manual/printing/?c=007

TheBugLife

Messages : 208
Date d'inscription : 12/01/2014

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: CONFIG EEPROM

Message par Talocks le Mar 29 Juil - 18:23

je viens également de changer ma vis d'axe Z.

La modification de la ligne dans le fichier configuration.h n'a étrangement eu aucun effet, j'ignore pour quelle raison mais l'imprimante n'a pas pris en compte le changement de pas.

Ayant au préalable modifié la ligne qu'indique TheBugLife pour pouvoir avoir de nouveau accés à l'eeprom (serais-ce l'origine du pb ?), je m'en suis sorti en rentrant les commandes suivantes dans Repetier (onglet "Manual control", ligne "G-Code") :

M501
Ceci permet d'afficher les données enregistrées dans l'eeprom

la ligne qui nous intéresse est celle-ci :
M92 X64.25 Y64.25 Z2560.00 E600.00
Il s'agit en gros des rapports de démultiplication en X (X64.25), Y (Y64.25), Z (Z2560) <- celle qui nous intéresse et de l'extrudeur (E600)

On tape la ligne suivant :
M92 Z1600

On enregistre :
M500

On relit de nouveau les paramètres de l'eeprom afin de vérifier si les paramètres ont bien été pris en compte :
M501

Normalement on doit (entr autre) voir ça :
M92 X64.25 Y64.25 Z1600.00 E600.00

Voilà, j'ignore toujours pourquoi chez moi la modification du fichier configuration.h n'a pas fonctionné, si c'est également ton cas tu pourras aussi essayé cette méthode, à conditions d'avoir bien réactivé l'accès à l'eeprom.

Talocks

Messages : 73
Date d'inscription : 06/05/2014

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: CONFIG EEPROM

Message par PAPILLON le Mer 30 Juil - 8:43

Bonjour
merci à talocks et the buglife pour ces conseils.
petite question : comment trouvez vous la valeur z de 1600 ?
en commande manuelle si je demande une descente de Z de 10 mm : j'ai en realité une descente de 11,53 mm.

Et pourquoi changer la valeur de l'extrudeur ( de 600 à 746).
Par ailleurs : je ne sais pas si il y une relation de cause à effet ,mais: j'ai installé arduino et suivi les conseils de chargement de "marlin". imprimante connectée et alimentée , j'ai maintenant acces à l'eeprom . (alt E) mais toutes les valeurs du tableau sont à zero .
Conclusion : j'avoue que je suis perdu .
merci pour votre aide.
Philippe
Ps: il va sans dire que je cherche aussi de mon coté ,mais que mes connaissances lacunaires en anglais et autres domaines ne me facilitent pas la tache  Embarassed

PAPILLON

Messages : 87
Date d'inscription : 03/06/2014

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: CONFIG EEPROM

Message par PAPILLON le Mer 30 Juil - 11:43

Bonjour .
j ai modifié "#define EEPROM_CHITCHAT" et fait le reversement dans l'eeprom . j ai maintenant acces aux valeurs .Z= 2560 - E = 600
avec le calculateur je trouve 2133.3333 pour TR 8*1.5.
Comment se calcule cette valeur ?.
dois je egalement changer la valeur de E.?
Une fois "reverser" dans l'eeprom et en demandant un déplacement z de 10 mm , le comparateur affiche 9.22 mm. je vais donc affiner la valeur pour avoir 10.00 mm
Merci pour vos conseils qui me permettent d'avancer.
PHilippe

PAPILLON

Messages : 87
Date d'inscription : 03/06/2014

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: CONFIG EEPROM

Message par Talocks le Mer 30 Juil - 17:55

Bonsoir,

La valeur de 1600 avait été donnée par TheBugLife dans son post sur le changement d'axe :

Modification de l'axe Z

Pour le changement de la valeur de l'extrudeur, celui-ci n'est absolument pas lié à celui de l'axe Z. Certains le modifie afin de s'assurer d'avoir le bonne quantité de filament entrainée. Il arrive en effet que lorsque l'on demande 10cm, on n'en ai que 9 d'avaler.

Les valeurs du tableau à 0 et inaccessible dans Repetier, il me semble (à confirmer/infirmer) que cela est une conséquence inévitable du changement opéré à la ligne #define EEPROM_CHITCHAT. Etant un peu habitué à la console sous Linux, cela ne me gêne absolument pas.

Talocks

Messages : 73
Date d'inscription : 06/05/2014

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: CONFIG EEPROM

Message par TheBugLife le Mer 30 Juil - 19:22

#define EEPROM_CHITCHAT permet la lecture et l'enregistrement de nouvelles valeurs dans l'EERPOM

la valeur Z1600 correspond à la une vis TR au pas de 2mm

j'ai modifié la valeur de E afin d'avoir une sortie de fil réelle

@Talocks
Talocks a écrit:La modification de la ligne dans le fichier configuration.h n'a étrangement eu aucun effet, j'ignore pour quelle raison mais l'imprimante n'a pas pris en compte le changement de pas.

La valeur utilisée doit être celle de l'EEPROM ce qui a pour effet de ne pas prendre en compte la valeur en dure dans le code. Pour cela, il suffit de réinitialiser les valeurs pas défaut ce qui aura pour effet de prendre les valeurs en dure dans le code

J'espère avoir répondu à vos questions et n'hésitez pas à demander de nouveau si cela n'est pas claire pour vous.

TheBugLife

Messages : 208
Date d'inscription : 12/01/2014

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: CONFIG EEPROM

Message par Talocks le Mer 30 Juil - 20:56

Si besoin, comment peut on réinitialiser les valeurs par défaut afin de prendre celles configuration.h ?

Talocks

Messages : 73
Date d'inscription : 06/05/2014

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: CONFIG EEPROM

Message par PAPILLON le Dim 3 Aoû - 11:04

Bonjour
je rentre et prends en compte vos messages . Merci pour vos conseils . tout fonctionne au poil . j'ai un déplacement de 10.21 mm pour 10 mm demandés .cette "erreur est tolérable à mon avis .
Philippe

PAPILLON

Messages : 87
Date d'inscription : 03/06/2014

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: CONFIG EEPROM

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum