J'y arrive pas !

Aller en bas

J'y arrive pas !

Message par BertrandL le Ven 29 Déc - 15:03

Salut à tous,
Débutant, de chez débutant, et après une casse du coupleur réparé, j'ai fait quelques impressions sur ma K8201, j'avais quelques models sur ma carte SD, impeccable!, J'ai voulu aller un peu plus loin, et imprimer des stl, que j'avais chargé, et certains de mon cru.
Mon problème est le suivant: j'ai Repetier-Host+ Slic3D, pour le chargement des stl dans Repetier, pas de problème, mais quand j'essaye de les trancher, pour generer mon gcode, il me dit qu'il ne trouve pas le fichier en gcode qu'il voudrait, et en suivant le chemin qu'il m'indique, je trouve un fichier, mais en .obj.
Je suis assez nul en informatique, et surtout en impression 3D, j'ai donc du faire, ou ne pas faire un truc.
Est ce que quelqu'un pourrait me briffer un peu sur le sujet, siouplait, il aurait droit à ma reconnaissance éternel.

Ps: je bosse sur Solidworks, et mes stl sont bons, après vérif.



BertrandL

Messages : 16
Date d'inscription : 26/11/2017

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: J'y arrive pas !

Message par statis le Ven 29 Déc - 23:09

Salut BertrandL
Normalement tu fais "add" pour charger le STL et ensuite "export GCODE" quand tu es sur l'interface SLIC3R.
Mais avec repetier les commandes sont peut-être différentes...
avatar
statis

Messages : 1196
Date d'inscription : 18/03/2014

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: J'y arrive pas !

Message par BertrandL le Sam 30 Déc - 10:08

Salut statis,
Suite à tes infos, je suis passé directement sur Slic3r, mais après les réglages et les réparations nécessaires, voilà ce que j'ai, quand j’essaie d’exporter mon gcode.

BertrandL

Messages : 16
Date d'inscription : 26/11/2017

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: J'y arrive pas !

Message par BertrandL le Sam 30 Déc - 12:21

Bon, petit à petit j'avance, j'ai réinitialisé les réglages d'origine, et après quelques tâtonnements, j'y arrive, enfin pas trop mal.
Mais j'ai encore un petit problème: en fin d'impression, mon extrudeur ne se remet pas au point 0. mais au bord et au milieu du plateau, et non pas en bas à gauche. J'ai du rater un réglage, mais lequel ?

BertrandL

Messages : 16
Date d'inscription : 26/11/2017

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: J'y arrive pas !

Message par statis le Sam 30 Déc - 14:02

Salut BertrandL,
C'est dans Printer settings / Custom Gcode / end-gcode que cela se passe :
M104 S0 ; turn off temperature
G28 X0 ; home X axis
M84 ; disable motors

Le G28 X0 va mette X en position 0 et laisse Y et Z en place.
Il ne faut surtout pas toucher à Z car la buse doit toujours être plus haute que l'objet en fin d'impression et assez loin de lui.
Tu peux tenter de modifier la ligne en rajoutant Y0 :
G28 X0 Y0 ; home X Y axis
La buse sera placée en avant gauche.
A la rigueur tu peux désactiver la ligne en mettant un ; devant :
;G28 X0 ; home X axis
et rajouter une ligne :
G1 Z205
La buse va monter au plus haut pour bien laisser l’accès à la pièce.
Par contre pour la K8200 il vaut mieux câbler un bouton reset en super accessibilité chaque fois que l'on touche au GCode car si par exemple la commande G1 Z205 ne fait pas ce qu'il faut, tu casse tout et pire si tu coupe le courant (risque de cramer les drivers de moteurs).

Se dire que cela serait mieux que le plateau se positionne en plein milieu en mettant un G28 X Y (les valeurs de X et Y sont optionnelles pour la commande G28) suivie d'un G1 Z 205 pour avoir un meilleur accès à la pièce est une mauvaise idée car seul le 0 est sur pour une perdeuse de pas comme la K8200.
Ce type de réglage de fin d'impression est réservé à des imprimantes avec des sécurités de fin de courses, la K8200 de brelleman n'en a pas...

Dans ton cas, je ne toucherais à rien sans être sur d'avoir des sécurités sur ma K8200...
avatar
statis

Messages : 1196
Date d'inscription : 18/03/2014

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: J'y arrive pas !

Message par BertrandL le Sam 30 Déc - 18:11

merci statis,
Miracle!, j'ai compris ce que tu m'a expliqué, je m'améliore, d'heure en heure. cheers
Je vais tester la G28 en XY à 0, ça devrait le faire.
C'est surtout pour éviter que mon ventilo ne shoote mes pièces, en fin. J'aurais pu le changer de place, et faire un Home à chaque fois, mais je suis tellement faignant, que ta solution a ma préférence. Very Happy
Et puis c'était comme ça au début. scratch
Pour le Z en 205, pour l'instant je ne rencontre pas de problème à ce niveau, alors je le laisse comme il est.
Mais ne pourrait-on pas mettre comme pour le gcode de départ: home all axes ?

BertrandL

Messages : 16
Date d'inscription : 26/11/2017

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: J'y arrive pas !

Message par statis le Dim 31 Déc - 12:53

Salut BertrandL

Non, Z ne doit pas revenir à 0 avec une pièce sur le plateau car le trajet de l'extrudeur pourrait le mette en collision avec elle selon l’espace qu'elle occupe.
Même avec Simplify3D qui a un mode "pièces multiples l'une après l'autre", le slicer n'est pas capable d'éviter une collision si l'utilisateur ne les place pas sur le plateau en prévoyant les dégagement nécessaires pour le passage de l'extrudeur.

Ton ventilateur ne peut pas toucher la pièce sinon c'est qu'il est plus proche du plateau que ta buse. Exemple buse à 0.2mm et ventilateur à 0.1mm avec Z à 0 alors qu'il devrait être au moins à 0.4mm...

avatar
statis

Messages : 1196
Date d'inscription : 18/03/2014

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: J'y arrive pas !

Message par BertrandL le Lun 1 Jan - 15:10

Salut statis,
Ok, compris pour Z, c'était juste un questionnement, sinon mon problème est réglé, j'ai rajouté Y0 en G28, et ça marche nickel

BertrandL

Messages : 16
Date d'inscription : 26/11/2017

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: J'y arrive pas !

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum