problème de température d'extrudeur K8203 suite court circuit CTN

Aller en bas

problème de température d'extrudeur K8203 suite court circuit CTN

Message par lucifer41 le Jeu 9 Aoû - 2:21

bonjour,
J'ai eu un souci en remontant mon extrudeur (le ctn à explosé) et depuis la température sous répétier indique 94.4 degrés même si je débranche le connecteur du CTN sur la carte.
Quand je branche un autre CTN la température passe à 94.6
si je fais chauffer l'extrudeur la température réelle monte "normalement" mais répétier indique une température qui monte très lentement.
à 105 indiqué, je dois être au alentour de 230-250.
Quelqu'un as t'il une solution?
Au pire, es ce possible de piloter la température de l'extrudeur en passant par le circuit du lit chauffant que je n'utilise plus?
Merci

lucifer41

Messages : 18
Date d'inscription : 19/06/2018

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: problème de température d'extrudeur K8203 suite court circuit CTN

Message par lucifer41 le Jeu 9 Aoû - 14:42

j'ai regardé un peu le fichier pin.h dans marlin.
Si je change les valeurs #define HEATER_0_PIN 10 et #define TEMP_0_PIN 13
ainsi que #define HEATER_BED_PIN 9 et #define TEMP_BED_PIN 14
es ce que je vais pouvoir brancher mon extudeur en lieu et place du lit chauffant?

lucifer41

Messages : 18
Date d'inscription : 19/06/2018

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: problème de température d'extrudeur K8203 suite court circuit CTN

Message par statis le Jeu 9 Aoû - 20:49

Tu aurais du poser ta question uniquement ici, tu aurais eu une réponse plus rapide...

Lit chauffant plus utilisé ?
Ouvre un sujet sur l'astuce pour se passer d'un lit chauffant alors que les meilleurs filaments ont besoin qu'il soit chaud...
En plus si la CTN du lit n'est pas raccordée il devrait y avoir une "error_min_temp"...

230/250 degré mesuré sur le nez, comment ?
Il manque un bon sujet sur les mesures fiables du nez...

Bon passons au vif du sujet, le circuit de la CTN...
Sans commentaire sur repetier VS afficheur avec plus de fiabilité sur les informations données.
En partant du principe que repetier ne fait pas n'importe quoi (pas sur) ou est le problème ?
Dans la remontée d'information venant de la CTN...

Plusieurs causes possibles, regardons d'abord le schéma :
http://www.open-electronics.org/wp-content/uploads/2013/04/schema-base.jpg
Un condensateur et une résistance avant d'attaquer le circuit intégré...

Aucune valeur précisée donc difficile de savoir si ce sont les mêmes résistances/condensateurs donc si c'est possible d'inverser le rôle des circuits...

En cas de court-circuit CTN/filerie de la CTN la résistance (qui normalement devrait avoir une valeur prévue pour ce cas) pourrait avoir souffert et cela serait visible sur la carte (pas sur).
Toujours en cas de court-circuit le condensateur ne craint rien...
Un court-circuit mettant à la "masse" l'entrée du circuit intégré a peu de chance de flinguer quoique se soit...
Pourtant connecteur enlevé repetier remonte 94.6 alors qu'il devrait y avoir un message "min_temp_error"...
Je pencherais pour un problème non visible sur la résistance mais comme on ne connaît pas la valeur pour la vérifier, c'est embêtant...

Donc déjà être sur de la CTN serait une première bonne étape.
D'abord vérification de l'isolement en mesurant les deux fils par rapport à l'alimentation sous tension (CTN non raccordée au connecteur). Si aucune tension n’apparaît entre 1er fil et +/- et 2eme fil et +/- (4 mesures en tout) l'isolement est bon. Sinon toute la filerie est à remplacer.
Ensuite mesurée à vide avec un ohmmètre on devrait trouver la valeur par rapport à la température ambiante dans le tableau suivant :
https://www.tinytronics.nl/shop/index.php?route=product/attachmanager/getfile&product_attach_file_id=552
Si la valeur paraît bonne il serait intéressant de la raccorder sur le connecteur CTN du lit et voir ce qui dit repetier.
Si la valeur est bizarre, ne surtout pas faire de test...
Le lit pouvant monter à 120° au niveau du circuit il serait possible ensuite de raccorder aussi le nez sur le connecteur et de monter à cette température en surveillant la carte pour voir s'il n'y a pas un échauffement anormal (ce qui ne devrait pas être le cas car le lit et le nez ont normalement presque la même puissance.
Après tenter la modification du firmware en solution temporaire...
avatar
statis

Messages : 1282
Date d'inscription : 18/03/2014

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: problème de température d'extrudeur K8203 suite court circuit CTN

Message par lucifer41 le Ven 10 Aoû - 17:53

bon ça m'a saoulee ,j'ai commandé Ramps1.4 Controller Board pour Reprap Prusa Mendal Arduino Mega2560 + ELEGOO Carte Mega 2560 R3 ATMEGA 16U2 Micro Contrôleur Module Board avec Câble USB pour Arduino Board Noir + TopDirect E3D V6 Bowden Kit Extrudeuse à Tête-J Hot End avec 5pcs 1.75mm Tube D'extrudeuse + 10pcs Laiton Buse de Thermistance NTC3950 pour RepRap I
t'en pense quoi statis?

lucifer41

Messages : 18
Date d'inscription : 19/06/2018

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: problème de température d'extrudeur K8203 suite court circuit CTN

Message par statis le Ven 10 Aoû - 22:41

Qu'avant de commander il faudrait tourner son argent sept fois dans sa poche.

Perso je suis pas fervent du PC qui pilote l'imprimante, je ne vois pas d'afficheur avec commande autonome et lecteur de carte SD...
Encore plus perso, je déteste tout ce qui est bowden mais j'ai vu de bons résultats sur une Da vinci mini qui est équipé comme çà (avec en plus un plateau "froid").
Les buses laitons peuvent contenir du plomb, cela fera l'économie d'achat de filament sans perturbateur endocrinien à usage alimentaire mais pour travailler avec des inox il faut de l'extrudeur puissant...
avatar
statis

Messages : 1282
Date d'inscription : 18/03/2014

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: problème de température d'extrudeur K8203 suite court circuit CTN

Message par lucifer41 le Ven 10 Aoû - 23:12

très bonne remarque sur le cuivre, je prends note.
Je crois qu'il y a livré de l'inox, je te dirai et te montrerai des photos du résultat.
Quand au fait de passer par le pc, c'est que je veu pouvoir "controler en direct" sans avoir à passer par un support. mais c'est un achat que je pense faire rapidement ensuite.

lucifer41

Messages : 18
Date d'inscription : 19/06/2018

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: problème de température d'extrudeur K8203 suite court circuit CTN

Message par statis le Sam 11 Aoû - 9:12

mais on peut contrôler en direct avec le module afficheur...
regarde dans marlin les menus de l'afficheur et tu remarqueras que cela rend vraiment autonome Wink
par contre le PC sert quand on règle le PID car l'afficheur (peut-être pas tous) ne donne pas les messages de retour des commandes...

désolé hier je n'avais pas trop le temps de revenir sur la commande "impulsive" due au ras-le-bol des problèmes sur une K8200.
Saoulé on veut résoudre le problème en "un coup" et on commande pas toujours ce qu'il faut, pas toujours au bon prix...
La K8200 est en "mode coma", on aimerait la réveiller ?
Je crois que lorsque l'on a une K8200 il faut apprendre à s'en passer sur les longues périodes de résolution de tous les problèmes qu'elle aura les uns après les autres.
Certains problèmes pourront être corrigés si elle peut encore imprimer d'autres demandent du temps et surtout la partie extrudeur.
Les problème de chauffe vont saouler car même avec une tête toute montée pour remplacer celle d'origine, les "principes" ne sont pas idéaux...
Et ton problème me fait penser que je suis nul en "stratégie impression 3D"...
Flinguer le pilotage de la résistance de chauffe ne devrait pas arriver.
Monter à de grandes températures pour certains filaments, comme par exemple le nylon, peut être problématique.
La K8200 a une alimentation insuffisante...
Donc remplacement (obligatoire dans mon cas car HS) par un modèle plus puissant (toujours en 15 volts) et très volumineux en "achat impulsif".
Le plateau de la K8200 ne chauffe pas assez si pas alimenté en 24 volts donc beaucoup plus tard mise en place d'une deuxième alimentation avec cette tension et d'une taille avec un bon compris "place restante sur la K8200"/puissance.
Bien sur le plateau n'est plus commandé direct par la carte mais par un "power expander" (que l'on peut faire soi-même).
Suite à ton sujet je me dis "pourquoi je n'alimenterais pas mon bloc de chauffe via un power expander ?" pour protéger la carte et en 24 volts pour pouvoir le monter en puissance de chauffe.
Cela implique d'autres modifications dont le changement de mes deux alimentations (mettre une 15 volts de la même taille que ma petite 24 volts et une 24 volts plus puissante à son emplacement), à cause de manque de place.
Je me retrouve donc en partie bloqué à cause de mauvais choix de départ, je trouverais une solution qui amènera d'autres problèmes par la suite...
Protéger la partie "chauffe" est une chose mais ton problème est du côté thermistance...
Pas de "relayage" possible pour protéger la carte.
Fiabiliser la captation de température comme je l'ai fait sur mon montage http://3dprinting.forumactif.org/t424-nouvelle-buse?highlight=nouvelle+buse , oui mais pas de sécurisation de la carte...
Je voulais retravailler mon bloc de chauffe...
Je ne pensais pas qu'il était possible de flinguer le circuit de la thermistance, je dois donc stabiliser ma K8200 en protégeant la carte car même si j'ai un spair ramps/mega2560/afficheur cela va me gonfler grave de monter tout cela à cause d'une panne que je préférerais éviter...
Ton problème a au moins un côté positif, je vais plus réfléchir avant de me lancer dans une nouvelle galère, merci pour çà Wink
avatar
statis

Messages : 1282
Date d'inscription : 18/03/2014

Voir le profil de l'utilisateur

Revenir en haut Aller en bas

Re: problème de température d'extrudeur K8203 suite court circuit CTN

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum