Forum Imprimante 3D en français - K8200 & autres
Vous souhaitez réagir à ce message ? Créez un compte en quelques clics ou connectez-vous pour continuer.
-43%
Le deal à ne pas rater :
-43% sur la carte mémoire microSD SanDisk Extreme PRO 400 Go
104.66 € 184.99 €
Voir le deal

Extrudeur inactif pendant impression

Aller en bas

Extrudeur inactif pendant impression Empty Extrudeur inactif pendant impression

Message par Envoiedubois Jeu 16 Avr - 9:20

Bonjour
J'ai depuis maintenant environ 6 ans un 3Dison PRO de chez ROCKIT.
Cela faisait pas mal de temps que je ne l’utilisais plus.
Au redémarrage, quelques soucis qui m'ont déjà pas mal ennuyé.
Après quelques modifications, j'ai décidé de la recâbler proprement.
Suite à cela, problème d'extrusion à l'impression.
En clair, lorsque je charge / décharge le filament, cela fonctionne.
Mais lorsque je lance l'impression, elle n'extrude pas.
La température monte, elle est bien lue par la machine, les axes se déplacent, mais l'extrudeur ne tourne pas.
Help me!!
Pour info, c'est un clone de makerbot
Merci pour vos lumières, les miennes sont en train de griller les unes après les autres, et les neurones avec.
Pour info, j'ai déjà pas mal testé de choses, changement des câbles, connexion aux autres driver, tout est OK.
Peut-être le souci d'un paramètre température de protection de l'extrudeur qui serait mal paramétré, dans le firmware.
Ah oui, la cerise sur le gâteau, je voulais utiliser un autre firmware, mais là, impossible de lire ce qu'il y a dans la machine, et encore moins de changer le firmware.
Merci d'avance
Je joins le fichier information de la machine.


System Information
CreatorK version: v90
Java version: 1.6.0_16
Machine
Profile Name: The 3DISON PRO
Driver Type: MightySailfish
Name: 3DISON PRO
Motherboard firmware version: Unknown v7.5
Motherboard communication statistics
Number of packets received from the USB interface:0
Number of packets sent over the RS485 interface:0
Number of packets sent over the RS485 interface that were not responded to:0
Number of packet retries attempted:0
Number of bytes received over the RS485 interface that were discarded as noise:0
Machine Driver XML:
<machine experimental="0">
<name>The 3DISON PRO</name>
<geometry type="cartesian">
<!-- different pulleys on X and Y axii -->
<axis endstops="max" homingfeedrate="2500" id="x" length="290" maxfeedrate="18000" stepspermm="80.000000"/> <!-- Pulley dia: 10.82mm / 1/8 step = 1/(10.82 * pi / 1600) -->
<axis endstops="max" homingfeedrate="2500" id="y" length="205" maxfeedrate="18000" stepspermm="80.000000"/> <!-- Pulley dia: 10.82mm / 1/8 step = 1/(10.82 * pi / 1600) -->
<axis endstops="min" homingfeedrate="1100" id="z" length="245" maxfeedrate="1170" stepspermm="400"/> <!-- Actual length is 157mm, we reserve ~5mm for safety. TR-8x8 Z axis = 1/(8/1600) -->
<axis endstops="none" id="a" length="100000" maxfeedrate="6400" stepspermm="96.275201870333662468889989185642"/> <!-- stepspermm is incoming filament length, see comment at bottom for explanation -->
<axis endstops="none" id="b" length="100000" maxfeedrate="1600" stepspermm="96.275201870333662468889989185642"/> <!-- stepspermm is incoming filament length, see comment at bottom for explanation -->
</geometry>
<tools>
<tool default_rpm="3" diameter="0.4" fan="true" heatedplatform="false" heater="true" index="1" model="Mk8" motor="true" motor_steps="3200" name="Mk8 Left" stepper_axis="b" type="extruder"/>
<tool default_rpm="3" diameter="0.4" fan="true" heatedplatform="true" heater="true" index="0" model="Mk8" motor="true" motor_steps="3200" name="Mk8 Right" stepper_axis="a" type="extruder"/>
</tools>
<wipes>
<wipe X1="-135.0" X2="-135.0" Y1="55.0" Y2="45.0" index="0" purge_duration="1000" purge_rpm="5.0" reverse_duration="15" reverse_rpm="35.0" wait="1000.0"/>
<wipe X1="-135.0" X2="-135.0" Y1="55.0" Y2="45.0" index="1" purge_duration="1000" purge_rpm="5.0" reverse_duration="15" reverse_rpm="35.0" wait="1000.0"/>
</wipes>
<offsets>
<offset xNozzle="33.0" yNozzle="0.0" zNozzle="0.0"/>
</offsets>
<clamps/>
<driver name="mightysailfish">
<!-- optional: <portname>COM1</portname> -->
<rate>115200</rate>
</driver>
<warmup>
</warmup>
<cooldown>
M18 (Turn off steppers after a build.)
</cooldown>
<bookend autoend="machines/edison/Pro_Auto_End.gcode" autostart="machines/edison/Pro_Auto_Start.gcode" dualstart="machines/edison/Dualstrusion_start.gcode" end="machines/edison/Pro_end.gcode" start="machines/edison/Pro_start.gcode"/>
</machine>


Envoiedubois

Messages : 4
Date d'inscription : 16/04/2020

Revenir en haut Aller en bas

Extrudeur inactif pendant impression Empty Re: Extrudeur inactif pendant impression

Message par statis Jeu 16 Avr - 22:56

Salut Envoiedubois,

On est mal patron...

Pour les imprimants à firmware proprio il faut prier de ne jamais avoir de problème de ce côté là...

Pour les autres problèmes il faut trouver un contact SAV constructeur.
Les chinois parlent anglais et répondent, si si...

Par contre les chinois ne sont pas des lumières...

Sinon je ne comprends pas...
Dans ce type d'imprimante le chargement fait sortir du fil fondu et donc si ce point fonctionne il n'y a aucune raison pour que cela bloque à l'impression...

La sortie du fil indique que la thermistance n'est pas endommagée, que le résistance est fonctionnelle et que l'ensemble driver/moteur est bien géré par la carte.

Sans assez d'information je verrais plutôt un problème côté slicer.
Mais je ne pourrais pas t'aider car le GCODE doit être du même style que ma Dreamer, c'est à dire un truc exotique...

Donc essaie d'envoyer un mail à info@rokit.co.kr en expliquant dans la langue de jexpire ton problème.

Bonne chance...
statis
statis

Messages : 1398
Date d'inscription : 18/03/2014

Revenir en haut Aller en bas

Extrudeur inactif pendant impression Empty Re: Extrudeur inactif pendant impression

Message par Envoiedubois Ven 17 Avr - 9:13

Salut Statis
Merci pour ton retour, et oui, comme je le penses aussi, on est mal…
Juste une question, concernant les imprimantes qui ont une sécurité pour ne pas extrudé à froid, le système est aussi actif au chargement du filament?
Je penses que oui.
Je vais m'atteler à demander à Rokit le firmware original pour essayer de le recharger.
Car sur leur site, le firmware ne semble pas correspondre à ce que j'ai besoin, car impossible de l'uploader dans mon imprimante.
Encore merci et bonne journée.

Envoiedubois

Messages : 4
Date d'inscription : 16/04/2020

Revenir en haut Aller en bas

Extrudeur inactif pendant impression Empty Re: Extrudeur inactif pendant impression

Message par statis Ven 17 Avr - 12:12

Bonjour Envoiedubois,

Toutes les imprimantes doivent avoir une sécurité pour ne pas extruder à froid.
Dans les firmware "marlin" il faut envoyer une commande GCODE particulière pour extruder à froid ce qui dans le cas d'un calibrage sans buse peut être intéressant.
Juste pour l'info :
https://reprap.org/forum/read.php?110,487480

Dans le cas ou la sécurité soit enlevée ou que la thermistance donne une température plus élevée que la réelle et donc trop basse pour l'extrusion, le filament n'ira pas plus loin que la buse, le moteur va brouter et en observant le fil on voit qu'il a été creusé à l'emplacement de la roue d’entraînement.

Les séquences de chargement de filament sur les imprimantes qui ont cette fonction dans leur firmware, la tête chauffe et le filament n'est envoyé que lorsque la température cible est atteinte.
Si la température cible est mal paramétrée le filament ne sort pas de la buse.

Ton filament sort au chargement donc le problème est ailleurs.
Cependant il y a une différence entre le chargement et l'impression.
Au chargement il n'y a qu'une petite quantité de filament envoyée.
La buse peut être encrassée, ou la température un poil trop basse, ou le système d’entraînement trop faible, voir les 3 ensemble...
Si la roue d’entraînement ne fait pas bien contact avec le filament ou carrément n'est pas solidaire du moteur il n'y aura pas de trace sur le filament...
Quand on peut pousser le filament à la main il est possible de sentir que la température n'est pas bonne à la "résistance"...

Changer un firmware ne doit se faire que par obligation surtout que la plupart des pannes viennent d'ailleurs.
Surtout parce qu'il faut le firmware spécifique à la version de ta machine. Exemple une Dreamer peut avoir des poulies grises ou des poulies noires, j'ai du razer la mienne et heureusement que le firmware permet la modification via le panneau d'affichage car cela faisait cogner le bloc d'impression en butée.
Charger un mauvais firmware peut faire du dégât...

Comme tu as chargé un firmware incertain il te faut vraiment le bon...

Le premier faux ami en impression 3D est le slicer...
Lorsque l'on a un problème d'impression il est bien de regarder le GCODE envoyé à la machine.
Exemple, une température trop basse spécifiée dans les commandes et l'impression ne démarre pas...

Le mieux est de te faire aider par un SAV qui connaît la machine et les softs livrés.
statis
statis

Messages : 1398
Date d'inscription : 18/03/2014

Revenir en haut Aller en bas

Extrudeur inactif pendant impression Empty Re: Extrudeur inactif pendant impression

Message par Envoiedubois Ven 17 Avr - 12:39

Et bien, je trouve que je suis déjà bien démerde et débrouillard, mais là, ca me fait plaisir une réponse d'un gars qui semble maitriser plus (beaucoup plus) que moi.
Et le fait d'être externe au problème te rend plus observateur et réfléchis que moi, car là je sature.
Merci pour les précision.
Pour ce qui est de là liaison poulie crantée et moteur, j'ai le même problème sur les deux moteurs, car comme c'est une double tête j'ai aussi tester avec l'autre en le branchant à la place du premier, donc pas cela en cause te j'ai bien revérifié.
Du coup tu m'oriente vers le slicer, je vais creuser cela ce soir, car le firmware est toujours celui d'origine dedans.
Je pensait juste qu'il pouvait buger
Et pour le SAV, ben en ce moment pas facile, et en Suisse, on est pas gâté niveau impression 3D:D
Merci vraiment pour ton aide et ta perspicacité, je te redonnerais des nouvelles.

Envoiedubois

Messages : 4
Date d'inscription : 16/04/2020

Revenir en haut Aller en bas

Extrudeur inactif pendant impression Empty Re: Extrudeur inactif pendant impression

Message par Envoiedubois Ven 17 Avr - 22:19

Bonsoir
Alors voilà, j’ai bien, très bien avancé !
Je me suis dit que tu avais raison que c’était donc sûrement le Slicer
J’ai Slicer un STL, et j’ai supprimé ligne par ligne les commandes.
Et miracle, après la chauffe, le travail débute, mais pas d’extrusion, et en supprimant la ligne contenant G162 le moteur tourne!!
Maintenant il me reste à trouver pourquoi comment j’ai ce code ou si il a toujours été là et pourquoi il bug
Merci encore

Envoiedubois

Messages : 4
Date d'inscription : 16/04/2020

Revenir en haut Aller en bas

Extrudeur inactif pendant impression Empty Re: Extrudeur inactif pendant impression

Message par statis Dim 19 Avr - 21:51

Bonsoir Enviedu bois,
Je ne maîtrise pas, pas moyen de comprendre pour quoi il y a un G162.
Comment un slicer peut-il demander d'aller en butée (maximum des axes) au lieu d'aller en origine...
Je ne vais pas pouvoir t'aider sur le coup...
statis
statis

Messages : 1398
Date d'inscription : 18/03/2014

Revenir en haut Aller en bas

Extrudeur inactif pendant impression Empty Re: Extrudeur inactif pendant impression

Message par statis Dim 19 Avr - 22:02

par curiosité j'aimerais bien voir le fichier généré par le slicer (sans modifications) jusqu'aux commandes de déplacement d'impression...
statis
statis

Messages : 1398
Date d'inscription : 18/03/2014

Revenir en haut Aller en bas

Extrudeur inactif pendant impression Empty Re: Extrudeur inactif pendant impression

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum